Why can't Amazon Quicksight connect to Heroku Postgres?

Resolution

Amazon Quicksight requires that SSL connections be negotiated with CA-verifiable certificates. Heroku Postgres does not currently support verifiable certificates. Our certificates will change when the underlying hardware has issues and we move your database away from it. As such, Quicksight is currently incompatible with Heroku Postgres.