Why does my application fail to build on the new heroku-18 stack?

Issue

Applications fail to build on the new heroku-18 stack (https://devcenter.heroku.com/articles/heroku-18-stack).

Resolution

Your application may fail to build on the new heroku-18 stack because your app is incompatible, due to changes in packages available in the stack, as well as available language runtimes.

In order to change stacks, please use heroku stack:set (https://devcenter.heroku.com/articles/upgrading-to-the-latest-stack), specifying the previous stack you were using (either cedar-14 or heroku-16), and deploy a new release.

Ask on Stack Overflow

Engage with a community of passionate experts to get the answers you need

Ask on Stack Overflow

Heroku Support

Create a support ticket and our support experts will get back to you

Contact Heroku Support
Terms of Service Privacy Cookies © 2018 Salesforce.com